Our Detrack app can run on any Android phone installed with Android 2.3 (Gingerbread) or higher. However, we recommend at least Android 4.0 i.e. Ice Cream Sandwich (ICS), Jelly Bean (4.1, 4.2, 4.3), KitKat (4.4), etc. or higher for more reliable performance.